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Aim 

 

 

The aim of this tutorial is to teach the user to import and visualise raster 

data in GPlates.  

 

 

Included Files 

 

 

Click here​ to download the data bundle for this tutorial. 

 

 

For this tutorial we will be using a few different sets of files. These 

include: 

 

● Time-dependent raster sequences of reconstructed ocean floor age 

as published by Seton et al. (2012) from the EarthByte group. 

 

● Sample raster images of time-dependent dynamic topography 

created by Bernhard Steinberger, based on a dynamic topography 

model published by Müller, Steinberger et al. (2008) 

 

● The MIT-P08 tomography model of the P-wave velocities published 

by Li et al. (2008) 

 

● A detailed colour image of the global topography and bathymetry 

published by the US National Oceanic and Atmosphere 

Administration: color_etopo1_ice_low.jpg 

 

● A coastline file: 

Seton_etal_ESR2012_Coastlines_2012.1_Polygon.gpmlz 

 

 

ftp://ftp.earthbyte.org/earthbyte/GPlates/TutorialData_GPlates1.5/3.1-Introduction_to_Rasters_and_Time-Dependent_Rasters_Data.zip


● A rotation file: Seton_etal_ESR2012_2012.1.rot 

 

This tutorial dataset is compatible with GPlates 1.5. 

 

Background 

 

GPlates gives us the functionality to do age-based masking of raster 

data,and this means any age-grid can be used to mask underlying rasters 

which in turn can be cookie-cut by polygons and rotated to their position 

in the past. It is also possible to specify a surface extent of any longitude 

and latitude range for the raster, enabling rasters of a smaller size to be 

correctly sized and positioned on the globe.  

 

In this tutorial we will be working on importing and visualising raster data 

in GPlates and rotating and masking raster data back through time. For all 

those computer illiterate folk out there, a raster is simply a file which is 

made of 2-dimensional grid of pixels and is stored as JPEGs or grid files 

like netCDF. This is different to vector data we have used in previous 

tutorials, that are composed of points, lines and polygons. 

 

Exercise 1 – Loading and visualising raster data

 

This first exercise is going to walk you through the steps of importing a 

a raster into GPlates. 

 

File → Import → Import Raster → Raster_Tutorial_Data → 

color_etopo1_ice_low.jpg​ (Figure 1) 

 

 

 

 



Figure 1.​ Selecting the raster (color_etopo1_ice_low) from the Import Raster window 

 

The dialogue then will ask you to assign a certain band to the raster 

image (Figure 2). You can choose between the “band 1” when loading a 

normal raster (as you are now) or “age” depending on whether it is a 

Time-dependent raster. Chose “band 1”. Select “Next”. 

 

 

 

 

 

Figure 2. ​Assigning raster band names 

 

A Georeferencing Box will open (Figure 3). ​ ​This dialogue box enables you 

to set the geographic extent of the raster. The default is set to a global 

extent. As we want the raster to cover the globe check the extents are set 

to ​top and bottom as 90.000° and -90.000° respectively, and left and 

right as -180.000 and 180.000 respectively​. Later on in this tutorial we 

will go through an example of using a regional raster.​  Select “Next”. 

 

 

 



 

Figure 3.​ Assigning Latitudinal and longitudinal extent to raster 

 

 

The final step is to create a feature collection. Select “Create new feature 

collection” and select finish (Figure 4).  

 

Note in the bottom of this box there is a message informing you that the 

raster metadata (​metadata is loosely defined as data about data) will be 

saved in a GPML file in the same directory. Instead of importing the raster 

again, you can simply go to File → Open Feature Collection 

 

 



 

Figure 4.​ Creating a feature collection for raster 

The raster color_etopo1_ice_low should now be displayed on the globe 

(Figure 5).  

 

 



Figure 5.​ color_etopo1_ice_low raster imported into Gplates successfully. 

Exercise 2 – Time dependent rasters: Global dynamic 

topography 

 

Now we will visualise time-dependent rasters in GPlates. Time depednent 

rasters are a series of rasters that have been age-coded so we can 

observe the evolution of a dataset through time. In the following 

exercises we will be observing snapshots of geodynamic models of 

dynamic topography (Appendix. A) and depth slices from seismic 

tomography models which are coded to geological age. 

 

 

Dynamic topography is vertical motion of the Earths surface attributed to 

mantle processes. For example, dense, sinking material, such as 

subducting slabs, drag down over-lying crust, whereas buoyant upwellings 

push up overlying crust. For an informative overview of dynamic 

topography, the 2001 Scientific America article “Sculpting the Earth from 

Inside Out by Professor” by Mike Gurnis is a good place to start. 

 

In this exercise we will be importing a sequence of time-dependent raster 

images showing geodynamic model results of dynamic topography since 

the Mid-Cretaceous (0–100 Ma), provided by Bernhard Steinberger (GFZ 

Potsdam). These images have been generated at 1 Myr intervals. 

 

1. Load the time-dependent rasters using the following sequence of 

commands: File→ Import Time-Dependent Raster (Figure 5).  

 

 

 



 

Figure 5.​ Navigating the menu bar to import time-dependent raster sequences. 

 
Select the 'Add directory...' button and locate and select folder called 

“Dynamic Topography” → “jpg” in the tutorial data bundle (Figure 6). 

Press ‘Select Folder’ (you cannot select an individual JPEG when loading a 

Raster Sequence), press ‘Next”, and leave the band name as “band 1”. 

Press ‘Next’ and as our rasters are global, ensure that the lat-lon bounds 

are 90◦ to -90◦ and -180◦ to 180◦. Press ’Next’ again and create a new 

feature collection by selecting Done. You can also tick the checkbox in the 

last dialogue to save a *.gpml file storing your settings. 

 

 

 



 
Figure 6.​  Once a directory has been selected, the series of jpegs contained within that 

directory will be displayed next their corresponding age. 

 

 

2. To make these rasters more geographically meaningful, let’s open a 

coastline file and add this to the GPlates main window: Go to File → Open 

Feature Collection and locate 

Seton_etal_ESR2012_Coastlines_2012.1_Polygon.gpmlz in the tutorial 

data bundle. Click Open to add the file. 

 

3. What are we missing? Unless we load a rotation file the coastlines (and 

any other datasets we want to visualise) will remain fixed in present-day 

coordinates. Go to File → Open Feature Collection and load in the rotation 

file Seton_etal_ESR2012_2012.1.rot 

 

4. Now use the Animation Controls and/or Time Controls in the Main 

Window above the globe (Figure 7) to reconstruct the image sequence 

back through time. Blues indicate faster seismic waves travelling through 

colder, denser material which pulls the lithosphere down resulting in 

negative dynamic topography, whereas reds indicate waves travelling 

through hotter less dense material which pushes the lithosphere up 

 



resulting in positive dynamic topography. To watch the evolution of the 

dynamic evolution of the Earth’s surface since 100 Ma, set the time to 

100.00 and then press the play button. See the Reconstructions section in 

the GPlates manual for more details about manipulating animations. 

 

 

 

Figure 7. ​Time and Animation controls in the main window. You may use these controls 

to manually enter a time, move the slider to reconstruct the globe or animate from a 

selected time to the present. 

 

 

Exercise 3 – Time dependent rasters: Dynamic 

topography and tectonics in Australasia

 

Time-dependent raster sequences can be combined with other 

reconstructable datasets in order to analyse and investigate features in 

the geological record. We will now exploit this functionality in order to see 

why dynamic topography is reflected in the geological record of several 

Australian basins and oceanic plateaus. Evidence for negative dynamic 

topography can be expressed as anomalous tectonic subsidence. By 

analysing stratigraphic data (obtained from exploration wells) we can 

calculate how a region has subsided over time. Anomalous subsidence is 

the long term lithospheric sinking that can not be explained by the usual 

reasons. That is subsidence expected from thermal cooling resulting from 

lithospheric stretching, or flexure due to the emplacement of a heavy 

load. Knowledge of the tectonic history of the region in question will 

further help determine if dynamic topography( the lithospheric 

topography changing due to mantle convection) is a potential cause of the 

anomalous subsidence. 

 

Cenozoic anomalous tectonic subsidence, induced by mantle convection 

processes, is recorded in wells north and northeast of Australia [e.g. 

DiCaprio et al., 2009, Heine et al., 2010, DiCaprio et al., 2010]. If 

subsidence has occurred, a basin will form and sedimentation will 

increase.Thus if the rate of sedimentation in your well core is greater than 

the sediment contribution from lithospheric stretching then you can 

attribute it to dynamic subsidence,and would check this suspicion against 

mantle convection models. In our example the dynamic topography, 

including a 300 m downward tilt of the continent to the north- east, is due 

to the Australian Plate migrating towards the subduction zones of 

Southeast Asia [DiCaprio et al., 2009]. We will now load into GPlates the 

outlines of the Carpentaria Basin (N of Australia), Queensland Plateau (NE 

 



of Australia) and Marion Plateau (NE of Australia); focus regions of the 

above authors. 

 

1. Locate and open the files ​CarpentariaBasin.gpml​, 
QueenslandPlateau.gpml​ and ​MarionTerrane.gpml​ from the tutorial 

data bundle. 

 

2. We will also load in the locations of several wells that have recorded 

anomalous tectonic subsidence in the Cenozoic. We will do this using the 

option to load files also from the Feature Manager: File → Manage Feature 

Collections. Click on the Open File button and load the file 

Wells_Australia.gpml​. 
 

3. We will now adjust the colouring of the line and polygon data to make 

it easier to see: go to Features → Manage Colouring (Figure 8) and from 

the Feature collection drop down menu select All → Single colour and 

select “Black” Figure 9). Now we can clearly see the coastlines, wells and 

basin/plateau outlines. 

 

 

 

Figure 8.​ Navigating the menu bar to open the Manage Colouring window. 

 

 



 

Figure 9​. Changing the colour of all feature data to black. 

 

 

4. Now play the animation through from 100–0 Ma. 

 

How does the dynamic topography signal evolve in the focus areas we 

have loaded? 

 

You will notice that the negative signal strengthens as Australia migrates 

in a north-northeasterly direction (Figure 10). 

 

 

 



 

Figure 10. ​View of the Australian region with Gulf of Carpentaria basin outline and the 

Duyken-1 well (black dot) as well as the Marion and Queensland Plateau polygons and 

other well data. Background are time-dependent dynamic topography images. 

 

 

 

Exercise 4 – Time dependent rasters: Seismic 

tomography and slab windows

 

For the next exercise you will require the following two regional raster 

bundles included in the tutorial dataset: 

 

Montelli06_S (Regional dataset) 

 

MITP0-08 (Regional dataset) 

 

We will now be using a combination of regional time-dependent rasters 

and reconstructable data sets to reveal an assumed Late Cretaceous-Early 

Tertiary ‘slab window’ beneath Sundaland (Whittaker et al., 2007) – a 

region of Southeast Asia comprising the Malay Peninsula, Borneo, Java, 

Sumatra and the surrounding islands. 

 

 

 



Slab windows 

Slab windows form as a result of spreading ridges intersecting subduction 

zones. When ridges are subducted the down-going plates continue to 

diverge, yet due to an absence of ocean water to cool the upwelling 

asthenosphere and form new oceanic crust, the plates no longer continue 

to grow and a gap develops and widens. Seismic tomography enables us 

to visualise slab windows from present-day and past subduction. 

 

Seismic tomography 

Seismic tomography is a method of imaging the Earth’s interior to reveal 

regions of past and present subduction, and hot mantle upwellings. It 

involves establishing how fast seismic waves (elastic waves) travel 

through the mantle, for example seismic waves generated by 

earthquakes. This information is then used to infer regions of anomalously 

hot or cold material; ‘anomalous’ is judged as deviating from a global 

reference model. As the speed of seismic waves travelling through the 

mantle is influenced by temperature, velocity can be used as a proxy for 

temperature (fast velocities = cold material, slow velocities = hot 

material). However, mantle composition also affects the speed of wave 

propagation, and therefore establishing correlations between velocities 

and mantle structures is not simple. 

 

The included data bundle includes 2 sequences of regional 

time-dependent raster images, and one global time-dependent raster 

sequence, showing seismic tomography. These images were generated 

from the seismic tomography model PRI-S05 (Montelli et al., 2006) and 

model MIT-P08 (Li et al., 2008). Although seismic tomography is a 

method for imaging the structure of the present-day mantle, by 

establishing a relationship between slab depth and slab age (i.e. when the 

slab was being subducted at the surface, NOT the age of the oceanic 

crust) we can use tomography data to learn about past subduction zones. 

By examining the relationship between subducted materials sinking 

velocity and its current depth, we can make estimates about the age of 

subducted material. Table 1 displays the corresponding depth of the age 

coded tomography slices. 

 

 

 

 



Table 1.​ Age – depth relationship for tomography slices based on Lithgow-Bertelloni and 

Richards (1998). 

 

 

 

 

 



You can load Time-dependent Raster Sequences, which are raster images 

whose pixels change according to the reconstruction time. 

 

Presently, GPlates can open RGBA images (which have a Red, Green, Blue 

and optional Alpha value for each pixel in the image) including common 

file formats such as JPEG (JPG), PNG, TIFF and GIF. 

 

 

If you want to load your own time-dependent raster set, make sure: 

- Each image is a jpg file 

- All files are named: name-time.jpg 

- The time-numbers are integers (time in Ma) 

 

 

Example: 

Montelli06_P-3.jpg 

Montelli06_P-4.jpg 

Montelli06_P-5.jpg 

etc. 

 

 

For our region of interest time-dependent raster sets already exists. The 

seismic tomography data shows the mantle structure at different depths, 

which are assumed to represent certain ages in the past. 

 

To load the Time-dependent Raster Sequence, select Import 

Time-dependent Raster from the File Menu (Figure 11). This will open the 

first ‘Import Time-Dependent Raster’ window. 

 

 

 



 

Figure 11.​ Under the File tab, select ‘Import’, ‘Time-dependent Raster’.  

 

 

To add raster images, we have two options. 

 

1. If we are using multiple files which are saved in a single folder, we can 

use the ‘Add directory…’ button and select the entire folder in which the 

images are saved. 

 

2. Alternatively, if we are using multiple files which are saved alongside 

other files we do not want to load, or use the ‘Add files...’ button and 

select them all individually. 

 

In this example, we will load the entire folder and use the Montelli 

tomography model. The importing Rasters data bundle also contains the 

MITP08 model, so feel free to try it out also. Keep in mind that for this SE 

Asia example, only the regional MITP08 model (MITP-08_Regional) is 

applicable. 

 

Click the ‘Add directory’ button. Navigate to the folder in which your 

Montelli06_S folder is saved, select it and then click ‘Select Folder’ (Figure 

12). GPlates will take some time to add the raster file sequence. Don’t 

close the window! 

 

 

 



 

Figure 12.​ Use the ‘Add directory’ button to select the folder in which your raster 

images are saved. In this example, this is the folder ‘Montelli06_S’ included in the 

tutorial dataset. 

 

 

You will see all the individual raster files loaded (Figure 13). Click Next. 

 

 



 

Figure 13. ​The first ‘Import Time-Dependent Raster’ window with all raster files loaded. 

 

 

In the second window, you are asked to specify band names. Keep the 

default and click Next. 

 

In the third window, under Georeferencing, you are asked to specify the 

location of raster using latitude and longitude. Since this is a regional 

raster, we are required to specify the position of the image to be in SE 

Asia. If we were instead loading a global raster, which spans the entire 

globe, we would keep the default location as is. 

 

 

For the SE-Asia Montelli data, the coordinates are: 

 

Top (lat): 30.0000° 

 

Bottom (lat): -20.0000° 

 

 



Left (lon): 80.0000° 

 

Right (lon): 130.000° 

 

Enter these coordinates in and click Next (Figure 14) 

(These coordinates are also suitable for the MITP08 raster) 

 

 

Figure 14.​ Enter the SE-Asia coordinates for the Montelli raster dataset (Top: 30°, 

Bottom: -20°, Left: 80° and Right: 130°) and click Next. 

 

In the fourth window, you are prompted to create a new feature 

collection. Keep the default (< Create a new feature collection >) and 

press Finish. 

 

After you have changed the Camera Position you should be able to see 

the seismic tomography for the SE-Asian region (Figure 15). 

 

 



 

Figure 15.​ Seismic tomography of the SE Asian Region, with the raster surface extent 

set. ​(a)​ Tomography model is Montelli06_S at 0 Ma. ​(b)​ Tomography model is MITP08 

at 50 Ma. 

 

We want to use seismic tomography to find a hypothesised slab window 

beneath Sundaland in the late Cretaceous-Early Tertiary. 

 

Slabs at subduction zones can be seen in seismic tomography images as 

regions of anomalously fast velocities (blue areas in our figures), because 

the slabs are colder and denser than the surrounding mantle. 

 

A slab window can be seen as a break in the fast subducted slab. 

 

The slab window is thought to have opened approximately between 70Ma 

and 43Ma and can be observed in different models at depths 

representative of these times. 

 

Because the raster images are time-dependent we can animate the 

seismic tomography through time. 

 

For the time-dependent raster sets that already exist for SE-Asia we can 

animate a period from 189 Ma to present day in 1 My time steps. 

 

 

To animate the changes in seismic tomography through time we use the 

Animation Slider at the top of the interface. To reconstruct to a particular 

time, type the required age in Ma into the ‘Time’ text box and press 

Enter. As an example, reconstruct to 50 Ma using the Montelli model 

 



(Figure 16). 

 

 

Figure 16.​ Reconstruct to a particular time frame by either typing the reconstruction 

time in Ma into the ‘Time’ text box (highlighted in blue, or using the Animation Slider to 

slide to the required reconstruction time (circled in black). Animate the changes in 

seismic tomography through time by pressing the Play button (circled in black) 

 

 

To start the animation, press the Play button. The animation will start in 

the past (at the age at which you initially specified) and end at present 

day. 

 

If you want to stop the animation press Pause (same button as Play). 

 

By using the Fast Forward and the Rewind buttons you can watch the 

reconstruction in small steps. Press the Fast Forward/Rewind button once 

to adjust the current reconstruction time by one timestep 

forwards/backwards. The default timestep is 1 Ma. 

 

You can also use shortcut keys: 

 

Ctrl (CMD) + I = forwards 

 

Ctrl (CMD) + Shift + I = backwards 

 



 

By keeping the button pressed or the shortcut keys held down you can 

move forwards/backwards faster. 

 

In the Animation Dialog (Figure 17) you can adjust the start and the end 

time for your reconstruction. To access this click Reconstruction menu and 

select Configure Animation 

 

 

Figure 17.​ Animation Dialog 

 

For our data you can choose any start time between 189 to 1 Ma. 

 

In the Animation Dialog (Figure 17) you can also adjust the frames per 

second and the increment per frame. 

 

Default settings are: 

 

200 Ma for the start time and 0 Ma for the end time of the 

animation 

 

5 frames per second 

 

1 Ma increment per frame 

 



 

If you want your animation to start at present day and go back in time 

you can choose Reverse the Animation from the Animation Dialog 

 

To find our slab window we don’t need our animation to start at 140 Ma. 

Change the start time for the animation to 80 Ma and the end time to 30 

Ma. 

 

Try to find the slab window in the different raster sequences. Look for 

red-yellow gaps that appear to break up a continuous blue band. The blue 

represents the colder oceanic slab being subducted, and the red 

representing the hot mantle upwelling through the gap or ‘window’in the 

slabs. 

 

You may find that turning off the coastlines layer by clicking the Eye in 

the ‘Layers’ window may make things less confusing (Figure 18). 

 

 

Figure 18.​ (a) Slab window in Sundaland using the Montelli06_S model at 70 Ma (left), 

56 Ma (middle) and 43 Ma (right) 

 

You will find that in the MITP08 model, a slab window begins to form at 

63 Ma when a section of red intersects a blue band, and disappears at 38 

Ma when the blue band becomes continuous once more (Figure 19). 

 

 



 

Figure 19.​ (a) Slab window in the MITP08 model at 63 Ma (left), 57Ma (middle) and 

44Ma (right) 
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Appendix 

 

Terminology 

GPML  

The GPlates Markup Language. GPML is a “dialect” of XML, in- corporating 

features of the Geopgraphic Markup Language. Essentially, the GPlates 

data model is using markup language to represent any feature (ie. 

geographic object). 

 

Sample data  

When you download GPlates from http://www.gplates.org, some sample 

data is included in your download. On Windows, this will be available after 

the installation in the GPlates folder at C:\Program Files\GPlates\GPlates 

[version]\Sample data. For the Mac, the download will leave you with a 

disk image (*.dmg) file. Mount the file by double-clicking, drag the 

GPlates application bundle into the Applications folder. The sample data is 

included as directory (“sample-data”) in the top level of the disk image. 

 

Raster data  

Raster images comprise 2-dimensional grids of pixels, or points of colour, 

that are stored in image files such as JPEGS or grid files like netCDF. Note 

that they differ from vector images that are composed of points and line 

segments. 

 

Feature  

Any reconstructable object which can be loaded in GPlates. Features can 

be lines, points or polygons or multi-* geometries as well as raster 

 



images. 

 

Slab windows  

Slab windows form as a result of spreading ridges intersecting subduction 

zones (Dickinson and Snyder, 1979). When ridges are subducted the 

down-going plates continue to diverge, yet due to an ab- sence of ocean 

water to cool the upwelling asthenosphere and form new oceanic crust, 

the plates no longer continue to grow and a gap develops and widens. 

Seismic tomography enables us to visualise slab windows from 

present-day and past subduction. 

 

Seismic tomography  

Seismic tomography is a method for imaging the Earth’s interior; 

revealing regions of past and present subduction, and hot mantle 

upwellings. It involves establishing how fast seismic waves (elastic waves) 

travel through the mantle, for example seismic waves generated by 

earthquakes. This information is then used to infer regions of anoma- 

lously hot or cold material; anomalous is judged as deviating from a 

global reference model (e.g. PREM Dziewonski and Anderson, 1981). As 

the speed of seismic waves travelling through the mantle is influ- enced 

by temperature, velocity can be used as a proxy for temperature (fast 

velocities = cold material, slow velocities = hot material). How- ever, 

mantle composition also affects the speed of wave propagation, and 

therefore establishing correlations between velocities and mantle 

structures is not simple. 

 

 

Age-depth relationship for seismic tomography 

The table below show the conversion of seismic tomography depth slice to 

a certain age. This can then be used as time-dependent raster sequence 

in GPlates. Sinking Rate is approximately 1.3m/yr. 

 

 



 

Table 2​. Age–depth relationship for tomography slices. Data is based on: The dynamics 

of sinking slabs Butterworth, N., Talsma, A.S., Müller, R.D., Seton, M, Bunge, H.-P., 

Schuberth, B.S.A., Shephard,G.E., in prep.  

 

 

 


