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Aim

 

This tutorial is designed to introduce the user to the functionalities that allow 

changes in crustal thickness to be visualised in deforming areas. 

 

Included files 

 

Click here​ to download the data bundle for this tutorial. 

The tutorial dataset (8.4-Crustal_Thickness.zip) includes the following files: 

Ex1-3 Project file: Crustal_Thickness1-3.gproj - includes the following: 

Rotation file: Global_EarthByte+230-0Ma_GK07_AREPS.rot 

Coastline file: Matthews_etal_GPC_inrev_Coastlines_Polyline.gpmlz 

North Atlantic Deforming Network files: 

ftp://ftp.earthbyte.org/earthbyte/GPlates/TutorialData_GPlates2.0/8.4-Crustal_Thickness.zip


Deforming Network Features: NATL_Deforming_EarthByte.gpml 

Continent Ocean Boundaries: 

NATL_BreakUP-COBs_Deforming_EarthByte.gpml 

Age Segments: 

NATL_Age_Segments_extinctDef_EarthByte.gpml 

Deforming Mesh: 

NATL_PhaseI_DeformationMesh_EarthByte.gpml 

 

 

 

Background

 

Deforming networks are useful for modelling plates that do not remain rigid. 

Crustal thickness does not remain constant during this deformation, and it 

can be useful to track and visualise in different ways how the crust changes 

thickness through time. 

 

There are two different ways to visualise crustal thickness in GPlates 2.0. 

The first is relative change, where we select the Scalar Type as 

‘gpml:CrustalThinningFactor’. The crust at this time is given a value of 1 and 

the crust at subsequent times is given a value that represents the proportion 

of change with respect to this time (eg set 120 Ma) i.e. crust with a value of 

1.5 has thickened in comparison to the initial thickness while crust with a 

value of 0.5 is thinner than the original crust. Hence the time that you 

originally reconstruct to in order to generate the points is ​very important​ for 

the relative crustal thickness calculations. It doesn’t matter where you 

reconstruct to, as long as you know what time you are reconstructing to and 

keep this in mind. 

 

The second way to visualise crustal thickness is by selecting Scalar Type 

‘gpml:CrustalThickness’. This allows you to specify the actual thickness of 

the crust when you generate the points. The default is 40 km however you 

can set it to whatever is most accurate for your region. As you visualise 

crustal thickness through time, rather than seeing the relative changes in 

thickness, you will be able to see the absolute changes to crustal thickness. 

It is also important to remember at what time you generate the points, as 

this will be the time that the crust is assigned a thickness of 40km. 

 

http://www.gplates.org/user-manual/LoadingAndSaving.html


Exercise 1 – Visualising crustal thickness changes in the 

North Atlantic  

This exercise is designed to introduce you to how GPlates represents and 

tracks changes to crustal thickness in a forward modelling sense, whereby 

relative changes to crustal thickness are calculated with respect to a time in 

the past. 

 

1. Open GPlates and load in the project file ‘Crustal_Thickness.gproj’ by 

either dragging and dropping it onto the globe, or File > Open Project... 

 

2. Rotate the globe such that the North Atlantic is in view at 120 Ma (Figure 

1). 

 



 

Figure 1:​ Screenshot of globe focused on North Atlantic at 120 Ma 

Notice that there is a polygon that is shaded silver. This is a deforming 

network of the North Atlantic and we will use it to visualise changes to 

crustal thickness through time. 

 

 

2. ​Ensure that the reconstruction time is set to 120 Ma​. This is the 

time we want to calculate relative changes in crustal thickness with respect 

to and your results will look different if you don’t begin at 120 Ma. 

 

3. Using the select feature tool, select the deforming network region by 

clicking anywhere in the silver shaded area (the boundary of the region 



should turn white once selected). 

 

4. Go to Features > Generate Crustal Thickness Points 

 

A new dialog should open where we will specify the parameters for 

calculating crustal thickness (Figure 2). The parameters are specific to each 

deforming region. 

 

 

Figure 2:​ Generate Crustal Thickness Points Dialog (Step 5) 

 

 

Now we will generate the points inside the deforming region that will be 

used to represent relative changes in crustal thickness (select scalar type 

‘gpml:CrustalThinningFactor’). 

 

5. Specify the following parameters (Figure 3): 

- Density level = 6 (default - specifies point density in the deforming 



region. See note at end of this exercise for more information) 

- Random offset = 0 % (default) 

- Plate ID = 0 (default) 

- Begin time = 120 Ma (this is the time we have reconstructed back to, 

to generate the points) 

- End time = 62 Ma (default) 

- Name = North_Atlantic_Crustal_Thickness (or whatever you’d like to 

call it) 

 

 

Figure 3:​ Generate Crustal Thickness Points window with specified parameters for North 

Atlantic  

 

6. Go Next > Create a new feature collection > Create 

 

You should now notice that there are green points within our deforming 

network region (Figure 4).These are the points that will represent crustal 

thickness and are confined to within the deforming region. 



 

 

Figure 4:​ Newly generated crustal thickness points within the deforming region 

 

7. Open the Layer Window (Window > Show Layers…) 

 

You should notice that two new layers have been produced - a green one 

(reconstructed geometries) and a dark grey one (reconstructed scalar 

coverages).  

 

8. Expand the options for the green reconstructed geometries layer (Figure 

5). 



 



 



Figure 5:​ Layer options for our crustal thickness points 

 

9. Under Inputs > Topology Surfaces, add a new connection to the North 

Atlantic deforming network (Figure 6).  

 

 

 

Figure 6:​ Layer options for our crustal thickness points showing the connection to the 

topology surface 

Note: Although we connect a deforming network in this tutorial, rigid 

topologies (pink layers) can also be used. 



 

 

10. Under Reconstruction Options, select ‘Yes’ for Reconstruct using 

topologies. This will bring up a new window where we set Topology 

Reconstruction Parameters as follows: 

- Youngest Age = 62 Ma (default) 

- Oldest Age = 120 Ma 

- Time Increment = 1 Ma (default) 

Leave all other options as default (Figure 7) then click OK. 

 

Note: If you do not select ‘Yes’, the crustal thickness will be calculated in 

relation to whatever topologies are loaded in GPlates. In this tutorial, there 

is only one layer of topologies loaded in, so it will reconstruct based on this 

by default. If, in other models, there are multiple topology layers loaded, 

this step becomes very important. 

 

 

Figure 7:​ Set Topology Reconstruction Parameters 



11. Expand the options under the dark grey layer and change the Palette 

Range to between 1.5 and 0.5, since we are looking at relative changes in 

crustal thickness and the original value is set as 1 (Figure 8).  

 

Note: the palette range can be changed to any range you’d like however it is 

recommended that 1 is in the middle since it represents the original crustal 

thickness at 120 Ma and the colours diverge appropriately. 

 

 



Figure 8:​ Changing the colour palette range (Step 12) 

With the default colour palette, crust that is thicker than at 120 Ma will be 

yellow/red, while crust that is thinner will be blue. 

 

12. Now change the reconstruction time to 62 Ma (Figure 9). 

 

 

Figure 10:​ Crustal thickness of North Atlantic 

Notice that the points are now all different colours. Based on our colour 

palette, points that are yellow/red denote a thicker crust than at 120 Ma, 

those that are blue denote a thinner crust than at 120 Ma, and those that 

are still green denote that the crustal thickness has not changed since 20 



Ma. 

 

13. Play the animation from 120 Ma - 62 Ma and see how the points move 

and denote changes in crustal thickness. 

 

We can see that the deforming region illustrates rifting between North 

America and Greenland, the crust is thinned. 

There are a range of other colour palette options to choose from if you don’t 

like the red/green/blue default colour range. 

 

14. Expand the Scalar Coverage options under the dark grey layer in the 

Layer window, and select ‘Choose Built-in Palette...’ (Figure 11). 

 



 

Figure 11:​ Layer window showing ‘Choose Built-in Palette…’ option 

A new window should open (Figure 12) where you can choose a range of 

different colour palettes, choose to invert the colour palette (tick ‘Invert’), 

decide on the number of classes and choose to make the colours discrete 

levels (tick ‘discrete’).  

 

 



 

Figure 12:​ Window showing a range of colour palette options 

15. Have a play around with the colours and when you are done with your 

modifications, click Close. 

 

Don’t forget to save your new feature collection with the crustal thickness 

points!  

 

 

 

Note:When specifying the point density in Step 6, we used a value of 6 and 

got a rather sparse coverage. Using a point density of 8 gives us a more 

detailed coverage (Figure 13). 

 



 

Figure 13:​ Crustal thickness of North Atlantic deforming region with point density of 8 with 



default colour palette showing relative crustal thickness changes 

Using a denser point coverage can also make the visualisation of relative 

crustal thickness change easier, especially if a discrete colour palette is used 

(Figure 14).  

 



 

Figure 14:​ Crustal thickness of North Atlantic deforming region with point density of 8 and 

modified colour palette (Discrete, Inverted, Spectral) 

 

Exercise 2 – Generate Velocity Points

 

It is also possible to show the velocities of deformed geometries.  

 

1. Ensure that the project file and the crustal thickness points from either 

Exercise 1 or 2 are loaded into GPlates (we will use the files from Exercise 1 

in this exercise). 

 

2. Change the reconstruction time to 120 Ma. 

 

3. At the top of the Layers window, select ‘Add new layer…’ and select the 

light blue Calculated Velocity Fields layer type, then click OK. 

 

4. Expand the options under the newly created layer and under Inputs > 

‘Velocity domains’, add a new connection to the green (reconstructed 

geometries) layer that represents your crustal thickness points. 

5. Under Velocity & Interpolation options, select Calculate velocities ‘of 

domain points’. 

Your options should look something like Figure 15 

 



 
Figure 15:​ Layer window showing options of the new Calculated Velocity Fields layer 

6. Play the animation from 120-62 Ma and see the arrows that appear, 

describing the motion of the deforming network (Figure 16). 



  

Figure 16:​ Deforming network and crustal thickness points at 62 Ma showing scalar 

velocities. 

 

Exercise 3 – Export scalar coverage to files

 

After following the steps in Exercise 1 to generate scalar coverage points to 

show crustal thickness through time, we can then export these to files, 

which can be used at a later time. 

 



1. Make sure that you have the appropriate files loaded into GPlates (dark 

grey Reconstructed Scalar Coverage layer). 

 

2. Reconstruction > Export > + Add Export  

 

3. Select (Figure 17): 

- A data type to export (‘Scalar Coverages’) 

- An output file format (‘GMT’ in this example) 

- Configure Export Options: 

- File Options (Export to a single file) 

- Domain Point Format Options (Longitude/Latitude GMT Default) 

- Include Options (Include dilatation strain rate) 

- Specify Output Filenames (you can change this or leave it as the 

default) 

 

 

Figure 17:​ Add Data to Export window for scalar coverage crustal thickness points 

3. Click OK and then ensure that we are animating the entire period that the 

crustal thickness points exist for (120-62 Ma) by changing the times in the 

Export window (Figure 18). 

 



 

Figure 18:​ Export window for scalar coverage crustal thickness points 

 

4. Specify the directory where you would like to export these files to and 

then click ‘Begin Export’ 

 

5. These files should now be in the target directory for later use  

 

 



 

Exercise 4 – Visualising crustal thickness changes in the 

Arctic

 

We will use a method similar to that in Exercise 1 to visualise changes in 

crustal thickness in the Arctic Region, based on a reconstruction by Gion et 

al. (2017). 

 

Download the files for this exercise from ​here 

 

1. If you have the files still loaded in GPlates from previous exercises, close 

them, or go File > Clear Session 

 

2. Load in all the downloaded files except the Readme by dragging and 

dropping them onto the globe, or File > Open Feature Collections. 

 

3. Rotate the globe such that the deforming region is in view, and change 

the reconstruction time to 63 Ma (Figure 19). 

 

 

ftp://ftp.earthbyte.org/Data_Collections/Gion_etal_2016_Tectonics.zip


Figure 19:​ Deforming network in the Arctic Region 

4. If your deforming network does not appear as a triangular network, 

expand the options beneath the gold Resolved Topological Networks layer 

and beneath Triangulation Colour Mode, select ‘Dilatation Strain’ (Figure 20). 

 

5. Enable clamping may be ticked as this will constrain the strain rate away 

from extreme values and decrease computational time (Figure 20). 

 

 

Figure 20:​ Changing Triangulation Colour Mode of Topological Network and enabling 

clamping 

 

 



5. Using the select feature tool, select the deforming network region by 

clicking anywhere in the triangulated area (the boundary of the region 

should turn white). 

 

6. Go to Features > Generate Crustal Thickness Points (**before you do this 

ensure your reconstruction time is 63 Ma). 

 

A new dialog should open where we will specify the parameters for 

calculating crustal thickness. The parameters are specific to each deforming 

region. 

 

7. Specify the following parameters (Figure 21): 

- Scalar Type = gpml:CrustalThinningFactor 

- Density level = 8  

- Plate ID = 0 (default) 

- Begin time = 63 Ma (this is the time we have reconstructed back to, to 

generate the points) 

- End time = Distant future 

- Name = Arctic_Crustal_Thickness (or whatever you’d like to call it) 

 



 

Figure 21:​ Specifying crustal thickness parameters 

8. Select Next > Create new feature collection > Create 

 

You should now have lots of green points within the deforming network 

region (Figure 22). You should also note that there are two new layers that 

have been created - a green Reconstructed Geometries Layer and a dark 

grey Reconstructed Scalar Coverages Layer (Figure 22). 

 



 

Figure 22:​ Crustal thickness points that have been generated. 

 

9. In the layer manager window, expand the options beneath the new green 

Reconstructed Geometries Layer (Figure 23). 

 



 

Figure 23:​ Layer options for our crustal thickness points 

10. Under Inputs > Topology Surfaces, add a new connection to the 

Eureka_Mesh_Gion deforming network (Figure 24). 



 

Figure 24:​ Layer options for our crustal thickness points showing the connection to the 

topology surface 

11. Under Reconstruction Options, select ‘Yes’ for Reconstruct using 

topologies. This will bring up a new window where we set Topology 

Reconstruction Parameters as follows: 

- Youngest Age = 0 Ma (default) 

- Oldest Age = 63 Ma 

- Time Increment = 1 Ma (default) 

- Tick “Deactivate points that fall outside a network” 

Leave all other options as default (Figure 25) then click OK. 

 



 

Figure 25:​ Set Topology Reconstruction Parameters 

 

11. Expand the options under the dark grey Reconstructed Scalar Coverages 

layer and change the Palette Range to between 1.5 and 0.5, since we are 

looking at relative changes in crustal thickness and the original value is set 

as 1 (Figure 26).  

 

Note: the palette range can be changed to any range you’d like however it is 

recommended that 1 is in the middle since it represents the original crustal 

thickness at 63 Ma and the colours diverge appropriately. 

 



 

Figure 26:​ Changing the colour palette range (Step 12) 

With the default colour palette, points where the crust is is thicker than it 

was at 63 Ma will be yellow/red, while points where the crust is thinner will 

be blue. 

 

13. Play the animation from 63-33 Ma and see how the colours of the points 

change to reflect changes in crustal thickness. 

 



 

Figure 27:​ Crustal thickness of Arctic 

14. Don’t forget to save the new layers you generated! 
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