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Aim

 

This tutorial is designed to introduce the user to the various aspects of 

computing velocities in GPlates.  

Included files 

 

Click here​ to download the data bundle for this tutorial. 

The tutorial dataset (9.6-Computing_Velocities.zip) includes the following 

files: 

Rotation file: Caltech_Global_20100713.rot 

ftp://ftp.earthbyte.org/earthbyte/GPlates/TutorialData_GPlates2.0/9.6-Computing_Velocities.zip


Topologies: Caltech_Global_20100713.gpml 

Coastline file: Seton_etal_ESR2012_Coastlines_2012.1.gpmlz 

 

For Exercise 3, you will use:  

Coastline file: Matthews_eral_GPC_inrev_Coastlines_Polyline 

Rotation file: Global_EarthByte+230-0Ma_GK07_AREPS.rot 

Deforming Network files: 

Deforming Network Features: NATL_Deforming_EarthByte.gpml 

Continent Ocean Boundaries: 

NATL_BreakUP-COBs_Deforming_EarthByte.gpml 

Age Segments: 

NATL_Age_Segments_extinctDef_EarthByte.gpml 

Deforming Mesh: 

NATL_PhaseI_DeformationMesh_EarthByte.gpml 

 

Background 

 

What is a mesh? What is it used for? 

 

A mesh is an equally spaced grid of coordinate points. The distance between 

the points is equal on a spherical surface such as the Earth​[1]​. The use of a 

mesh is critical in linking plate kinematics and geodynamic models. For 

example, CitcomS uses a static mesh that measures the velocity of the 

tectonic plates through time at each node. 

 

 

 



 

 

Figure 1:​ CitcomS 9-mesh global cap and node distribution 

 

 

 



 

Figure 2:​ CitcomS 9-mesh node distribution 

 

 

 

CitcomS Mesh Specifications​2 

 

CitcomS meshes can be either regional or global. A global mesh is composed 

of 12 diamond-shaped ‘caps’ – numbered from 0 to 11. The density of the 

mesh nodes can be adjusted. The global distribution of ‘caps’ can be seen in 

Figure 1. The rectangular projection does not preserve the uniform distance 

between the nodes, whereas an orthographic projection is a better 

representation of the inter-nodal distance (Figure 2). 

 

 

 



 

 

Figure 3: ​CitcomS Mesh – Cap 0 with 9 X 9 nodes (Left), and Caps 0 to 11 global 

distribution (Right) 

 

 

In Exercise 2 we will make each cap comprise 9 X 9 nodes (Figure 3). This is 

a reasonably coarse mesh, especially for mantle convection modelling 

purposes. Mesh caps are composed of n​2​ nodes (n being the number of 

points along each side of the cap), and so processing the velocity of denser 

grids increases proportionally to the square of the node numbers along each 

cap side (See Figure 4). 

 

 

 

 



Figure 4:​ The increase in mesh density follows the square law, meaning that computation 

time of velocities increases significantly with increasing mesh density 

 

GPlates uses a rotation file to reconstruct geometries through time. The 

geometry features are a set of intersecting lines, each assigned a Plate ID 

and thus move according to the information in the rotation file. These 

geometries can be used to create a set of dynamically-closed plate polygons. 

The result of this is that the surface of the Earth is split into a discrete 

number of tectonic plates to cover the temporal span of the plate kinematic 

model. The velocity of each plate through time will be tracked in GPlates by 

the mesh files we will create in the next exercise. 

 

At each time interval in GPlates the mesh nodes are assigned Plate IDs 

according to the plate polygon on which they are located. These velocities 

can be used as boundary conditions for mantle convection models, including 

CitcomS and TERRA. In this way GPlates provides a link between plate 

kinematics and mantle dynamic processes. 

 

In order to generate and export plate velocities through time, GPlates 

expects a rotation file and a file of dynamically-closing plate polygons, along 

with our mesh files. The sample data contains all the necessary input files.  

 

GPlates automatically displays the velocity vectors based on the dynamically 

closing polygon and rotation files. That means your data MUST contain 

topological polygons created in GPlates with assigned Plate IDs, as it reads 

the rotation file and calculates velocity vectors on the fly for each mesh 

node. 

 

Exercise 1 - Generating a Mesh File 

 

GPlates currently supports the generation of global mesh files. These mesh 

files consist of 12 caps that cover the globe (see CitcomS Mesh 

Specifications above). Each point in the mesh is a “sampling” location of 

velocity, for the tectonic plate in which it is located. This is a CitcomS 

standard. 

 

Ultimately the following steps will allow you to create velocity fields as input 

for mantle convection modelling in CitcomS. Information can be extracted 

for other purposes, CitcomS modelling is merely the example used here. 

 

The density of the mesh points can vary, and is dependent on your 

application. For the purpose of this tutorial, we will use a coarse mesh of 9 X 

9 nodes. 



 

1. Open GPlates and load in the following files 

- Caltech_Global_20100713.gpml 

- Caltech_Global_20100713.rot 

- Seton_etal_ESR2012_Coastlines_2012.1.gpmlz 

 

The coastline file has been included so that you can orient yourself on the 

globe (you may wish to make it invisible later). 

 

2. In GPlates, go to Features > Generate Velocity Domain Points > 

CitcomS… 

 

3. Our mesh file will have a 9 X 9 nodes resolution, so enter 9 into the 

‘nodeX’ box (9 will automatically be entered in the nodeY box) (Figure 5). 

 

 

Figure 5: ​The Generate Mesh Caps window enables you to define the resolution and saving 

destination of your mesh file. 

 

4. Enter the destination where you would like the save the mesh files (it is 

suggested that you make a directory called ‘Velocity_Tutorial’) > Select the 

Folder and then click OK. 

 

You will now notice that there are arrows all over the globe (Figure 6). 12 

mesh files with 9 X 9 nodes have been saved into the directory you 

specified. These files have also been loaded into GPlates. The files are 

named 9.mesh.X.gpml, where X is the cap number, ranging from 0-11. You 

can see that they are loaded by opening the Manage Feature Collections 

window (File > Manage Feature Collections). 

 

In Figure 6, the pink arrows correspond to the velocity vectors of the 

Indo-Australian Plate. The velocity vectors indicate both the ​magnitude ​and 

direction ​of motion. The plate velocity display is quite useful to assess 

shortcomings or bugs in plate tectonic models.  

 

 



 

Figure 6:​ The GPlates globe displaying polygon outlines and velocity vectors. 

 

 

4. Reconstruct and animate the globe through time and inspect visually how 

absolute plate velocities change through time. 

 

 

 

 

Exercise 2 - Computing Velocities of Topologies 

 

1. If coming directly from Exercise 1, go File > Manage Feature Collections > 

eject all the mesh files that were generated. Ensure that you still have the 

rotation file, coastlines and topologies loaded in. 

 

2. Open the Layers window (Window > Show Layers) 

 

3. At the top of the Layers window, click +Add new layer… > Select the light 

blue layer (Calculated Velocity Fields) 



 

4. Expand the options for the layer (Figure 7) 

 

 

Figure 7:​ Layer options for the new Calculated Velocity Fields layer. 

 

5. Under Inputs > Velocity domains > Add new connection > 

Caltech_Global_20100713 (Figure 8) 

 



6. Under Velocity & Interpolation options > Calculate velocities > ‘of domain 

points’ (Figure 8) 

 

 

Figure 8:​ Layer options for the new Calculated Velocity Fields layer. 

 

You should now notice that there are arrows along the topologies that 

represent the direction and magnitude of their motion (Figure 9). 

 



 

Figure 9:​ Calculated velocities of topologies. 

 

7. Reconstruct back to 50 Ma and play the animation forward. Look at how 

the velocities of the topologies change in direction and magnitude through 

time. 

 

 

 

Exercise 3 - Computing Velocities of Deforming Regions 

 



We looked at deforming networks in Tutorial 9.4 and now we will look at how 

to compute velocities for points within the network. 

 

1. File > Clear Session (if coming from Exercise 2) 

 

2. File > Open Project > Load in the file Velocity_Deforming.gproj 

3. Change the reconstruction time to 120 Ma and rotate the globe to the 

North Atlantic area (Figure 10). 

 

Figure 10:​ North Atlantic Deforming Region 



You will notice that the area is filled in with a triangulation, and is coloured 

white (no strain), red (extension) and blue (compression). 

4. Open the Layers window (Window > Show Layers if not already open) and 

expand the options for the gold layer (Resolved Topological Networks).  

5. Under Network & Triangulation options > Tick Show triangulation 

velocities (Figure 11) 

You should now have white arrows appearing along the boundary of the 

deforming region, which are proportional to the magnitude of motion, and 

show the direction of motion of the boundary of the deforming region (Figure 

11). 



 

Figure 11:​ White arrows show velocity (both magnitude and direction) of boundary of 

deforming region in North Atlantic 

6. Play the animation from 120-62 Ma to see how the velocity of the 

deforming region changes. 

7. Untick the ‘Show triangulation velocities’ box 

We will now compute the velocities for the inside of the deforming region. To 

do this, we must generate points within the deforming region - we will do 

this the same way that we generated crustal thickness points in Tutorial 9.4. 

8. Ensure the reconstruction time is 120 Ma. 



9. Select the deforming network using the Feature Inspection Tool 

10. Features > Generate Crustal Thickness Points 

11. Specify (Figure 12): 

- Density level = 8 

- Begin time = 120 Ma 

- End time = 62 Ma 

- Name = whatever you choose (eg. NATL_points) 

 

Figure 12:​ Generating crustal thickness points 

12. Click Next > Create a new feature collection > Create 

13. Expand the options of the new green (Reconstructed Geometries Layer) 

and under Inputs > Topology Surfaces > Add new connection > Select the 

gold layer (NATL_PhaseI_DeformationMesh_EarthByte) 



14. Under Reconstruction options > Reconstruct using topologies > select 

Yes (Figure 13) 

 

Figure 13:​ Layer window showing options for newly generated crustal thickness points 



15. In the new window, specify the youngest and oldest age (120 & 62 Ma 

respectively) > OK 

16. File > Manage Feature Collections > Save your new feature collection 

(possibly as ‘NATL_deform_points’) 

17. At the top of the Layers window, select +Add new layer… and select the 

light blue layer (Calculated Velocity Fields) 

18. Expand the options and under Inputs > Velocity domains > Add new 

connection > select your new layer (whatever you called it in Step 15). 

19. Under Inputs > Velocity surfaces > Add new connection > select the 

gold topological network layer (NATL_PhaseI_DeformationMesh_EarthByte) 

(Figure 14) 



 

Figure 14:​ Options for generating velocity domain points 

You should now have some black arrows appear within your deforming 

network (Figure 15).  



 

Figure 15:​ Velocity arrows within the deforming network 

Notice that the coverage of the arrows is rather sparse.  

20. Zoom in to the network and notice that more arrows begin to appear. 

This is because the arrow spacing is at 0.175 (default) (under Velocity & 

Interpolation options - Figure 14). 

21. Click the X next to the arrow spacing box so that the spacing is ‘Not 

limited’ and notice that all our points now have arrows on them showing 

their velocity (Figure 16) 



 

Figure 16:​ Velocity of each crustal thickness point 

22. Zoom out and see that this dense coverage of arrows is not ideal. 

23. Have a play around with the spacing of the arrows to find something that 

is more appropriate (starting at 0.175 is a good starting point). 

 

 

 

Exercise 4 - Exporting Velocities 



 

GPlates can export animations in a number of formats. For the purposes of 

creating velocity fields, only one is of interest to us. The output files 

generated will be in plain ASCII (GMT xy) format) 

 

We will export the velocities we generated in the deforming region (from 

Exercise 3) however this can be applied to any velocities that have been 

calculated. 

 

1. Reconstruction > Export…  

 

2. We will export velocities from 120 -100 Ma to present-day, with an 

increment of 1 Myr per frame - change the animate from and to times at the 

top of the window (Figure 17) 

 

 



 

Figure 17:​ Export window showing correct export times 

 

 

3. We must now specify what files we wish GPlates to generate > click Add 

Export.... 

 

4. In the ‘Add Data to Export’ window select Velocities and then the GMT 

(*.xy) format (Figure 18). Select the following: Export to a single file 

(deselect the Export to multiple files) and choose Magnitude / Azimuth (0 to 



360 degrees clockwise from North). Click OK (the Add Data to Export 

window should close automatically).  

 

 

Figure 18: ​The Add Export window enables you to choose which files GPlates will generate 

for your time interval. 

 

5. Choose the target directory where the output will be created and then 

click Begin Animation. The files will now be generated. To save time we have 

only selected 20 Myr of velocities to export. 

 

The velocity files are now saved in your selected target directory. A velocity 

file is generated for every point, every 1 Myr (as this was the interval 



chosen). The file will contain multiple columns, including Longitude, Latitude, 

Plate ID, Azimuth (clockwise from North) and the Speed (cm/yr) for these 

export options.  

For more detailed information about calculating velocities, see ​Tutorial 5.3​ or 

the ​GPlates User Manual 
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