Supplementary Tutorial 1: Pangea Workflow
[bookmark: GPlates_Tutorial_1_16644252515_9407895029054394][bookmark: Author_Kara_Matthews_EarthByte_8042520431624184]EarthByte Research Group, School of Geosciences, University of Sydney, Australia 
[bookmark: Aim_05035363991732977_36911702_10854327406144304]Aim 
This tutorial is designed to teach the user how to: 
1) Load vector data
2) Experiment with colours
3) 'Cookie-cut' data
4) Save data
5) Load raster data 
6) Reconstruct data (without agegrid)
7) Reconstruct data (with agegrid)
8) Export reconstructions (shapefiles and jpegs)
9) Create an animation (using Quicktime or sequimago)
Screen shots have been included to illustrate how to complete new steps within each exercise. 
[bookmark: Included_files_352643939027121]Included files 
The data bundle for this tutorial, ‘Supp1_Workflow', includes the following GPlates compatible feature files: 
· EarthByte Global Coastline File 
· EarthByte Global Rotation File
· EarthByte Global Static Plate Polygon File
· Volcano location dataset (USGS data)
· Downward Continued Gravity jpeg file (Whittaker et al. 2008)
· EarthByte Global Agegrid netCDF file (Müller et al. 2008)
See www.earthbyte.org/Resources/earthbyte_gplates.html for more EarthByte data sets. 
[bookmark: Background_7163274846887978_54_19329841113222435]Background 
[bookmark: Feature_Collections_9155219086]Feature Collections 
Data files loaded into GPlates are referred to as Feature Collections. This is because all data in GPlates are regarded as ‘features’ (e.g. MORs, volcanoes, etc) — whether geological or reconstructed data. For example, the EarthByte Global Coastline File contains the outlines of all the present day coastlines of the world, these coastlines can be thought of as features and therefore when we load the coastline file we are loading a ‘feature collection’. Basins, cratons, faults, hotspots, isochrons, mid-ocean ridges, seamounts, subduction aones, sutures and volcanoes are just some of the many other specific feature types handled by GPlates. Alternatively, a feature can remain ‘unclassified’. Rotation files are also loaded as a Feature Collection.
[bookmark: File_Formats_6459371935105304__9618014594716642]File Formats 
GPlates is able to load and save a number of data-file formats, including PLATES4 line (*.dat *.pla), GPlates Markup Language (*.gpml), ESRI shape files (*.shp) and GMAP VGP files (*.vgp). Additionally data can be exported in the GMT xy (*.xy) and GMT date-line split (*.gmt) formats.
See the GPlates online manual for further information: www.gplates.org/user-manual/LoadingAndSaving.html
[bookmark: Exercise_1_Loading_Data_387783]Exercise 1: Loading and Viewing Data 
Let's get started using Gplates!
1. Open GPlates 
2. File -> Open Feature Collection… (Figure 1). 
Locate and select: Global_EarthByte_GPlates_Coastlines_20110626.gpml and volcanoes.gpml
-> Open
*Hold down the Control (PC) or Command (Mac) key to select multiple files.
[image: ] 
Figure 1. How to load a Feature Collection into GPlates from the menu bar.
[image: ]Drag Globe Tool 
The world's coastlines (multi-coloured lines) and volcano locations (grey dots) are now displayed on the globe. Using the Drag Globe tool (see above) from the Tool Palette spend some time interacting with the globe; rotating it to see the different features. Once you have clicked this icon, click (and hold) anywhere on the globe and drag it (move the mouse around). While this tool is selected you can drag the globe as many times as you like and rotate it in any direction. You will learn more about controlling the view of the globe in the next tutorial.
Manage Feature Collections Window
The Manage Feature Collections (Figure 2) window is an alternative way to upload data sets. This useful option also enables you to save and unload data sets.
1. File -> Manage Feature Collections
2. You should be able to see all the layers you have loaded thus far. You can also load more files from this window. 
[image: ]Figure 2. The ‘Manage Feature Collections’ window.
The Layers Window
When data sets are loaded, a separate window, the Layers Window (Figure 3) should appear, where you can click on the 'Eye' symbol next to the layer name to switch it on/off, ie visible or invisible. This option is useful because layers can be made visible/invisible without being unloaded (ejected). This is a useful, time-saving feature that is especially handy when many different data sets are being viewed and analysed. It can reduce clutter on the globe and help the user to compare data sets without being overwhelmed with too many points, lines or polygons.
[image: ]Figure 3. The ‘Layers’ window, where you can make layers visible/invisible by clicking on the "Eye' icon next to the layer name.

Exercise 2: Changing Feature Colours 
In this exercise we will learn how to experiment with feature colours. Features in GPlates can be coloured according to their attributes or they can be assigned a single colour scheme. This functionality improves the user’s ability to effectively view and analyse data, particularly multiple data sets. By default features are coloured by Plate ID. Other colouring options include: Plate ID (by region), Single Colour, Feature Type and Feature Age. Note that you can only change the colour scheme for all features, not individual features.
As a first example we will colour our feature collections using a single colour.
1. Features -> Manage Colouring -> select All from the Feature Collection drop down menu -> Single Colour -> Blue (Figures 4 and 5)
[image: ]Figure 4. How to experiment with different feature geometry colours using the ‘Manage Colouring’ options.
[image: ]Figure 5. The Manage Colouring window.
Now spend some time trying the different colouring options (Figure 6).
[image: ]A [image: ]B 
[image: ]C [image: ]D 
Figure 6. Globe coloured by: (A) Plate ID (by region), (B) Feature Type, (C) Feature Age (default) and (D) Single Colour (customised: Add → choose colour from colour wheel).
GPlates also allows the user to colour data sets separately. So in this current example our coastlines can be coloured using a different scheme from our volcano locations.
2. Features -> Manage Colouring -> select the data set that you would like to colour differently from the Feature Collection drop down box -> untick the Use Global Colour Scheme Box → now select the colour scheme → Choose.
Now spend some time playing around with the various colouring options. Before you move on to the next exercise make sure you turn both the coastlines and the volcanoes to be coloured by Plate ID (volcanoes should be grey as they do not yet have plate id's assigned).

Exercise 3: Reconstructing Data on the Globe 
Now you will spend some time actually reconstructing the coastline data (for this exercise turn off the volcano locations dataset by clicking the eye in the Layer window). We will now employ the rotation file to reconstruct our coastlines back to 100 Ma.
Load the rotation file Global_EarthByte_GPlates_Rotation_20100927.rot
The easiest way to reconstruct data is by using the Time (Figure 7) and Animation tools (Figure 8). 
[image: ]
Figure 7. The Time tools enable you to jump to a certain time. 
[image: ]
Figure 8. The Animation tools in the Main Window enable you to reconstruct data back and forth through time. 
A quick and way to jump straight to a certain time is by using the Time Controls. Simply enter the time you wish to reconstruct to and press enter. 
1. In the Time Controls box type 100 Ma > Enter. Rotate the globe and have a look at where the continents were 100 Ma (Figure 9). 
[image: ]Figure 9. View of the coastlines at 100 Ma. Note that in the Time Controls box (top left) the time says 100.00 Ma. 
An alternative way to reconstruct your data is by using the Animation controls. You can simply click and manually move the time slider (notice that in Figure 10, the slider is no longer at the far right but is a third of the way along) or you may jump to a certain time and then “play” an animation of the feature data reconstructing. 
2. Make sure that you are still at 100 Ma (or jump to any time in the past) > press the play button in the Animation Controls [image: ]and watch the coastlines rotate back to their present-day positions. To animate the entire time period you have rotations for, first use the Reset button [image: ]to take you back to the oldest time you have rotations for and then press play. 
You may also watch animations of your data by using the Configure Animation option from the Reconstruction menu (Figure 10). 
[image: ]Figure 10. Animations can be manually configures from the Reconstruction menu. 
The Animate window provides you additional control over your animation (Figure 11). For example, you can specify whether you want to watch a reconstruction run backwards or forwards through time by clicking the Reverse the Animation button. 
[image: ]
Figure 11. The Animate window allows you to specify details about your animations. 
GPlates also enables you to change the anchored plate (Figures 12) so that you can reconstruct data keeping different plates fixed. 
[image: ]Figure 12. GPlates enables you to specify which Plate ID you keep fixed when reconstructing data. 
Spend some time altering the anchored plate ID to see the influence on the plate motions. For example, make an animation keeping South America fixed. 
3. Reconstruction > Specify Anchored Plate ID… > 201 > OK (Figures 12 and 13) 
[image: ] Figure 13. Nominating which plate to keep fixed. 
Once you have finished experimenting, set your anchored plate back to 000 (the spin axis – default). 

Exercise 4: Cookie Cutting Vector Data
GPlates allows “cookie cutting”, that is, data can be clipped using polygon geometries whereby a subset of the polygon’s features is copied over to the clipped data. For example, plate IDs can be assigned to a data set using a plate-polygon geometries, the plate IDs will then be assigned according to which plate polygon the individual features are enclosed by. The polygons that can be used to intersect the data may be in the form of non-topological features (static polygons) or ‘TopologicalClosedPlateBoundary’ features (dynamically closing polygons). Two plate polygon files (that outline tectonic plates) are currently available to the user: (1) a set of static (present-day) plate polygons and (2) a set of dynamically closing plate polygons (see below). 
A) EarthByte Plate Model 2009 Present Day Plate Polygon Files 
These polygons represent the boundaries of present day plates as well as presently preserved palaeo-plate boundaries. The polygons are broken up by age over the ocean floor based on the Müller et. al. (2008) present day agegrid. Plates that have been created or destroyed in the past are not incorporated into this model. The plate polygons are based on the EarthByte 2009 plate model. This dataset is compatible with the EarthByte present day coastline file. The file can be loaded into GPlates, other GIS software (such as ArcGIS, PaleoGIS, Quantum GIS, GRASS GIS, SAGA GIS, etc) as well as technical computing programs such as Matlab. 
B) Gurnis et. al. Dynamic Closed Plate Polygon Data Files 
These polygons represent continuously closing plates from 140 Ma to the present (see Gurnis et. al. Submitted for more details). Unlike the present day polygons listed above, these polygons dynamically change shape as the plate boundaries evolve. Plates that once existed in the past are incorporated. The plate polygons are based on the EarthByte 2007 global plate model. This dataset is best used for any global plate kinematic analysis, as boundary layer input into mantle convection software such as CitcomS and can be used to assign plate identifications to your dataset. The limitation of this dataset is its resolution, with only 40 plates existing during the last 140 Myrs. The plate polygons are available as GPML (GPlates Markup Language) files, which can be manipulated and translated to other formats with GPlates. The data are also available as static polygons in 1 Myr intervals. 
The rest of this exercise will use the static present-day plate polygons. We will now assign plate IDs to a global set of volcanoes using present-day plate polygons. 
You will notice that all the volcanoes are coloured the same colour (most likely grey – shown in orange in Figure 14 for easier viewing). If you query one of the volcanoes you will see that it does not have a plate ID. We will use cookie cutting to assign plate IDs. 
[image: ]Figure 14. View of South America showing volcano locations (orange). 
Let’s load a plate polygon file. 
1. File -> Manage Feature Collections -> Open file… -> select Global_EarthByte_GPlates_PresentDay_StaticPlatePolygons_20110622.gpml (this is the set of EarthByte static plate polygons) -> Open (Figure 15) 
[image: ]Figure 15. Coastlines, volcano data and the EarthByte set of static plate polygons are displayed on the globe. 
2. Features -> Assign Plate IDs… (Figure 16) 
[image: ] Figure 16. “Cookie cutting” is achieved using the Assign Plate IDs window. 
3. In the dialog that opens, tick the plate polygon file that you wish to you to cut the volcanoes data → Next (Figure 17) 
[image: ] Figure 17. The first step in cookie cutting is to select the plate polygon file you wish to use to cut the data. 
4. Now select the file you wish to cookie cut, i.e. the volcanoes file → Next (Figure 18) 
[image: ] Figure 18. The second step in cookie cutting data is choosing the dataset to cut. 
5. In the final window you must choose the cookie cutting specifications. We are only interested in cutting our data set according to present-day plate boundaries, so choose Present Day for Reconstruction Time (top box). In the Feature Partitioning box (middle) select the cookie cutting option. We only wish to copy over Plate IDs from the plate polygon file, so in the final box only select Reconstruction plate id → Apply (Figure 19) 
[image: ]Figure 19. Specifying how you wish to clip your data. 
Once GPlates has finished partitioning your data, you will see that the volcanoes have now been assigned plate IDs, and therefore they are coloured according to the plate that belong to (Figure 20). 
[image: ]Figure 20. Volcanoes now posses plate IDs as indicated by their colouring. 
If you reconstruct the globe back through time you will see that the volcanoes move fixed to the plates that belong to. You must save your data file to preserve this plate ID assignment – next exercise. 
Exercise 5: Saving Data Sets 
We will now see the different options available for saving data.
Open the Manage Feature Collections window and have a look at the different available actions.
1. File -> Manage Feature Collections
As you can see, the Manage Feature Collections dialog contains a table of controls and status information about the feature collections that are loaded in GPlates; each row corresponds to a single feature collection, and lists file name, format and available actions. There are three options (‘Actions’) available for saving data:
[image: ] Save – This first option simply saves the data file using its current name.
[image: ] Save As – This second option saves the data file using a new name.
[image: ]Save a Copy – This third option saves a copy of the file using a new name. If this option is selected then the original file will remain loaded in GPlates and the copy will be made in the selected destination.
In order to practice saving data we will save our volcano file with a new name e.g. 'volcanoes_PlateIDs.gpml'. You will see in the Manage Feature Collections window that this file is highlighted in red, signifying that there are unsaved changes to this file. Click the ‘Save As’ icon and enter the new file details in the Save File As window that appears (Figure 21). You can either leave the file format as GPlates Markup Language (*.gpml), or you can change it, say to a Shapefile format using the drop-down menu.
[image: ]Figure 21. The ‘Save As’ window where a new file name, and optionally a new file format, are specified.
Notice that the File Name in the Manage Feature Collections window has updated itself. You could now work on this file, for example add features to it, and not have to worry about modifying the original contents of the file.

Working with raster data 
Loading raster data 
Loading rasters in GPlates is very easy. Just use File → Import raster... as shown in Fig. 22a. In the case where the file has previously been loaded in GPlates, a new window will pop up and ask you whether you’d like to load the *.gpml instead. The first time a raster is loaded into GPlates, the application automatically creates a *.gpml file with the same basename as the original raster file. The next time you try to load the raster file, you can just open the *.gpml file as feature collection instead of importing the raster again. 
If you are loading a raster the first time into GPlates, the “Import raster” wizard will walk you through three main steps to allow GPlates to properly digest the data:   
[image: ](A) Import raster menu 
[image: ](B) Previously loaded rasters 
Figure 22. Loading rasters in GPlates. (A) Importing rasters in GPlates. (B) In case the raster has already been loaded into GPlates, a GPML feature collection is automatically generated (*.gpml) and the user is presented a dialogue which allows to chose from either, re-importing the raster or using the existing *.gpml file. 
Step 1. Raster Band Names: This dialogue ask you to assign a certain band to the raster image (Figure 23a). You can chose between the normal band in the raster “band 1” or “age” when the raster you are loading is an age grid. Chose “band 1” if you are loading a standard raster image without age information. Click Continue when you have assigned the information. 
Step 2. Georeferencing: At the moment, GPlates allows you to load either global rasters or rectangular rasters covering a region of the world. Adjust the georeferencing information accordingly (Figure 23b). For most of the sample data used in this tutorial you can mostly use the default settings (global extent). Click Continue. 
Step 3. Feature Collection: Lastly, GPlates will create a new feature collection with your imported raster (Figure 23c). You can select to save the new feature collection once the raster data has been imported, so the next time you can simply “Open” the *.gpml file instead of importing it again. Click Done. 
[image: ](A) Import rasters: Assign band 
[image: ](B) Import rasters: Georeferencing 
[image: ](C) Import rasters: New Feature collection 
Figure 23. Import raster wizard. If you load a new raster into GPlates, the “Import raster” wizard will ask you (A) to chose a band in the raster to be assigned, (B) questions about the georeferencing information of the raster image, and (C) whether you want to save your imported raster into a new *.gpml file. 
[bookmark: 3_2_Managing_raster_data_71975]Managing raster data 
There are two ways to manage raster data in GPlates, which can be confusing at first. The main distinction between those two options is that one works directly on the files, whereas the second one operates on the layers from loaded feature collections only (there might be cases when a *.gpml file contains different layers).  
(1) The first option is the file-centric “Feature manager”, which can be accessed through File → Manage Features or ctrl+m. 
(2) The second option is the “Layer” tool (Layers → Show layers) which controls the individual features (instead of working with the files on disk directly) and allows for functionality similar to layers in vector-graphic applications like Inkscape, Corel Draw or Adobe Illustrator. 
(1) Feature manager 
Once you have loaded features (rasters, vector data from shape files or other GPML data), these will reside in GPlates’ memory as feature collections. These individual loaded files can be shown using the “Manage Feature Collections” window. 
[bookmark: 3_2_2_Layer_tool_5916942196548](2) Layer tool 
In the “Layers” window (Layers → Show layers) feature collections can be displayed or hidden by clicking the 'eye' button on and off. 
Furthermore, dragging individual layers by the colored rectangle (grab it below the black triangle) allows you to change the visual order (stacking) of active feature collections. Different colored rectangles at the side illustrate different layer types. 

Exercise 7: Rotating rasters and age-based masking of raster data 
[bookmark: 5_1_Rotating_raster_data_52396]Rotating raster data 
To be able to reconstruct raster data, it needs to be assigned plateID information. 
Ensure the following files are loaded:
1. The global rotation file (Global_EarthByte_GPlates_Rotation_20100927.rot) 
2. The global static polygon file (Global_EarthByte_GPlates_PresentDay_StaticPlatePolygons_20100927.gpml) 
3. The global downward-continued gravity image (SS_gravity_downward_continued.jpg). File -> Import Raster -> Select SS_gravity_downward_continued.jpg -> Open -> Click continue in the Raster Band Names window -> Click continue to use global extents in the Georeferencing window -> Click Done in the Feature Collection window to create a gpml version of the jpg. (It may take your computer a little time to load the raster).
Once this has been done, you should have a something on your GPlates main window which looks like in Figure 24. 
[image: :Fig24.png]Figure 24. GPlates windows with sample data loaded. 
The next step involves telling GPlates to 'cookie-cut' the raster by assigning plateIDs to different portions of the raster using our global static polygon layer. Do the following: 
1. Make sure your layers are in the right order with the raster images at the bottom of the Layers window and the vector data (polygons) on top. If this is not the case, drag the layers into the proper order. 
2. Expand the image layer (the downward continued gravity image) in the Layers window by clicking the little black triangle to the left. 
3. In the “Inputs” section of the layer, click the “Add new connection” button under "Reconstructed Polygons:" and select the static polygons file from the list (Figure 25). 
[image: :Fig25.png]Figure 25. Adding a polygon connection to the downward continued gravity raster. 
4. Depending on your graphics card power, you will see that GPlates will need some little time to think before the main window becomes responsive again. 
5. Now you should be able to reconstruct to a to a desired time to rotate your global raster data to paleo-positions. See Figure 26 for an example rotated back to 50 Ma in an Australia-centric view. 
6. If you would like to see only the raster data and not have the polygons superimposed,simply toggle the polygon visibility off in the Layer manager. 
[image: :Fig26.png]Figure 26. Raster data cut to polygons and rotated back to 25 Ma. Notice that GPlates has automatically removed polygons and raster data which did not exist at this time (using the FromAge and ToAge feature attributes). 
[bookmark: 5_2_Age_based_masking_of_raste]Age-based masking of raster data 
GPlates uses advanced features of the graphics card and the OpenGL language to perform on-the-fly operations on the raster data using age-grid features. For this tutorial you need to additionally load the agegrid 6m.nc file. Before you can use the age-based masking functionality, you need to complete a few different steps: 
1. File → Import Raster → select agegrid_2008_6m.nc 
2. If you don't want to see the agegrid layer, turn it off by clicking the 'eye' in the Layers window 
3. Make sure the plate rotation file and the static polygon set are loaded. 
4. Ensure that the static polygon dataset is linked to the downward-continued raster data, as shown in Figure 25.
5. In addition, connect the age grid feature to the global gravity data. Click the "Add new connection button" below the “Age grid raster” heading in the Inputs subsection of the layer (Fig. 27) and select agegrid_2008_6m.nc from the list. 
6. You should now be able to reconstruct rasters again back through time, but with the age-based masking functionality enabled. Watch, for example the South Atlantic, as you go back in time you will see that the seafloor is succesively “eaten up” during the reconstruction at any timestep. The transitions are very smooth and not like the polygon-based disappearance. 
[image: :Fig27.png]
Figure 27. Layer manager showing how to link agegrid to the downward continued gravity raster
The age-based masking functionality provides on-the-fly masking of raster data using an age grid feature. The age grid specifies which pixel of a connected raster file get masked at a certain time, using advanced features of the graphics card and OpenGL. 
It is very important to note here that you need to be extremely careful when combining data sets by not mixing data using different rotation frameworks. For example, the age grid feature used for masking needs to be constructed with the same rotation parameters as the rotation file you are using to rotate your feature collections back through time. 
Naturally, one can also apply the age-based masking workflow to nonglobal/regional raster data which has been accurately georeferenced (Figure 28). 
[image: ]Figure 28. Regional combined SRTM (onshore) and free air gravity (offshore) image of the South Atlantic region rotated back to 84 Ma. The raster has been split into polygons and masked using the agregrid. Reconstruction in absolute reference frame. 

Exercise 8: Exporting Reconstructions
Now that you are able to reconstruct both vector and raster data, you may well wish to export a reconstruction to use in a presentation or publication.
Data can be exported from GPlates in a few different ways. Here we will look at exporting jpg images of reconstructions and also shapefiles of reconstructions.
Exporting jpg images of reconstructions
1. Reconstruction -> Export
2. In the export window (Figure 29) select 'Export Single Snapshot Instant'
3. Select a reconstruction time, e.g. 50 Ma
4. Click the 'Add Export Type' button -> in the '1. Select Data Type to Export' window select 'Raster'
5. In the '2. Choose Output File Format and Export Options' window select 'Joint Photographic Experts Group (*.jpg)' (see Figure 30)
6. Press OK
7. Select the target directory where you would like the jpg to be saved
8. Press Export Snapshot
You should be able to go to the directory specified in step 7 and find a raster named raster_50.00.jpg
[image: :Figure29.png]
Figure 29. Export Window
[image: :Figure30.png]
Figure 30. Selecting how you would like to export your reconstruction.
Exporting shapefiles (*.shp) of reconstructions
Exporting a shapefile version of a reconstruction is similar to the steps described above. Note that you can only export vector files as shapefiles (in our example the coastlines and volcanoes).
1. Reconstruction -> Export
2. In the export window select 'Export Single Snapshot Instant'
3. Select a reconstruction time, e.g. 50 Ma
4. Click the 'Add Export Type' button -> in the '1. Select Data Type to Export' window select 'Reconstructed Geometries'
5. In the '2. Choose Output File Format and Export Options' window select 'Shapefiles (*.shp)' You can select for all the reconstructed vector layers to be exported to one single shapefile, or to individual shapefiles.
6. Press OK
7. Select the target directory where you would like the shapefile to be saved
8. Press Export Snapshot
You should be able to go to the directory specified in step 7 and find either a single folder (named reconstructed_0_50.00 This is the all files saved as one shapefile option), or two folders (named volcanoes_PlateIDs and Global_EarthByte_GPlates_Coastlines_20110626 This is the all files saved as individual files option).
Making an animation
One easy way to make an animation of your reconstruction to show in a presentation is to use the recording function in Quicktime.
Another option is to export a sequence of images (Reconstruction -> Export -> Export Time Sequence of Snapshots) and combine them using software such as Quicktime, Windows Media Player etc to create an animation.
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. Choose Data Type to Export 2. Choose Output File Format and Export Options. e
Reconstructed Geometries Windows Bitmap (*.bmp)
Projected Geometries
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3. Specify Output Filenames.

Template: | raster_%0.21] lirg

A filename template uses printf-like format strings to specify where
the changing per-frame values should appear in the filename.

%n  frame number, in the range [1, N]
%u  frame index, in the range [0, (N-1)]

% reconstruction time of frame

%d  reconstruction time of frame (rounded to integer)

The precision of %f and padding of %d may be customised using
printf conversion specifiers (for example, "%0.2" or "%02d"). %n and
%u will be padded automatically to the width of the highest value.

Export raster data as image.
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